We will continue monitoring this over the next 24-48 hours, however all mitigation has been successful and services are operating as normal once again. Thank-You for your patience!
Posted Sep 02, 2026 - 18:43 UTC
Monitoring
This issue has been identified as a large scale DDoS attack. We've made appropriate adjustments and have confirmed stability is being restored. We will continue to monitor this as the time goes on.
Posted Sep 02, 2026 - 18:09 UTC
Investigating
We're aware of some general slowness in the platform affecting many users today. We're investigating this as related to a recent update and indexing protocols. We will update you as we have more information.
From time to you you may experience an occasional 500 error as the system recovers.